Oracle Apps DBA

My photo
More than 5+ Years of IT Experience in administering Enterprise wide Multi Vendor UNIX Servers, Oracle Databases (8i to 11gR2), Middle-tiers, Applications and Clusters. I am a Sun Certified System Administrator (SCSA) for Solaris 10, oracle 10g database certified associate(OCA), Oracle 10g Database certified professional (OCP) and Oracle E-Business suite R12 certified professionl(OCP)

Oracle Database and Applications

Monday, 28 February 2011

FRM-92101: There was a failure in the Forms Server during startup - R12.1.1

After successful completion of fresh installation of R12.1.1 on OEL(Oracle Eneterprise Linux 5.5), there was an error while accessing form server. All other services and application are working fine.

When we are trying to access form Server its giving error as below:




When we click on details:




This error message is because of the missing rpm openmotif21-2.1.30-11.EL5.i386.rpm on Linux OS.

You can download this rpm from http://oss.oracle.com/projects/compat-oracle/files/Enterprise_Linux/

After Installing this rpm bounce the middle tiers and access form server.

Issue must be resolved.

Happy reading :)

26 comments:

suhaib said...

Thank you very much , i faced the same problem and issue resolved by applying the rpm.

Regards,
Suhaib

Anonymous said...

thanks this helped me.. thanks for sharing..

Anonymous said...

is there any solution for this error in solaris 10 o/s

Syed Zaheer said...

Please make sure you have performed all pre-requisites (specially os patches and packages) before Installing it.

You can refer link:
http://appsdbaworkshop.blogspot.com/2010/11/oracle-applications-r1211-installation.html

regards,
Zaheer

Sidharth said...

hello,
after installing the patch, i am able to open the forms and reports.
i have one another problem. aftrer restarting the server i am not able to login into appslogin.
my all database, listner and forms, http services are working.
any solution on this?
sidharth

Syed Zaheer said...

Hi Siddharth,

Please make sure your autoconfig is completing without any errors.

Sidharth said...

Yes sunaid, my autoconfig completed successfully.

but when i was restarted my server. i am not able to open the AppsLogin page.

Syed Zaheer said...

Also make sure you've performed all per-requisites successfully.

Sidharth said...

Yes sirjii.!! I have installed all per-requisites before install EBS R12. I have successfully installed. i am able to open the AppsLogin.
but after restart i have faced the problem. can you pl. tell me what is the default ORACLE_HOME path in EBS R12.
thank you

Syed Zaheer said...

Make sure that you are using proper env files beofore starting your application.

Application environment file:

. APPSsid_hostname.env

File will be located under $APPL_TOP

thanks,
Zaheer Syed

Sidharth said...
This comment has been removed by the author.
Sidharth said...

can you pl. tell me exacts path
i guess below is path correct????
/d01/oracle/VIS/apps/apps_st/appl/APPSVIS_application12.env

pl guide me.

Syed Zaheer said...

Yes. This is correct one.

cd /d01/oracle/VIS/apps/apps_st/appl/

- and execute

. APPSVIS_application12.env

Sidharth said...

ok sirji, that mean. everytime when i started my EBS server i have to execute this .env file and after i have to run .sh file like below. is that correct.

. /d01/oracle/VIS/apps/apps_st/appl/APPSVIS_application12.env
vncserver :2
export DISPLAY-:2
/d01/oracle/VIS/inst/apps/VIS_application12/admin/scrpits/adstral.sh apps/apps

pl. guide

Syed Zaheer said...

Yes your are correct!

But make sure that file executed properly using command

echo $APPL_TOP --> Then it should return value:

/d01/oracle/VIS/apps/apps_st/appl/

thanks,
X A H E E R

Sidharth said...

Yes sirji,
I have create scripts file like this.
one thing is more which database version is default for EBS R12?
pl. guide

Syed Zaheer said...

By default 11.1.0.7 will be Installed with R12.1.1 release.

thanks,
X A H E E R

Sidharth said...

Thank you very much sirrjii, you are life saver.
thank you once again..:)

Syed Zaheer said...

Thanks siddharth for your kind words.

You're welcome :)

- Zaheer

ManaS said...

Hello ,
I have installed Oracle EBS 12i on oracle linux 5.5 .I encountered the same error and followed your inputs ,but while applying the patch I got below error .

{
Missing Dependency: libXp.so.6 is needed by package openmotif21-2.1.30-11.EL5.i386 (/openmotif21-2.1.30-11.EL5.i386)

}

Could you please let me know what I need to do here .

Syed Zaheer said...

Hi Manas,

Please insert OEL 5.5 DVD in your cd-rom and search for rpm "libXp-1.0.0-8.1.el5.i386.rpm". First install this rpm the install "openmotif".

If it still giving problem then update me.

regards,
X A H E E R

ManaS said...

Hi Syed,
Thanks for your reply .I have tried to install libXp-1.0.0-8.1.el5.i386.rpm and got the below error .


Public key for libXp-1.0.0-8.1.el5.i386.rpm is not installed

Regards
Manas

ManaS said...

Hi Syed ,

Thank You very much .

I used the below command
rpm -ivh libXp-.0.0-8.1.el5.i386.rpm
and its installed successfully .

Thanks for your help .Oracle Forms are now opening .

Thank you very much for your help .

Regards
Manas

Syed Zaheer said...

Hi Manas,

Glad to know that issue solved.

regards,
X A H E E R

Naeem Akhtar said...

I am getting this error on windows server 2008.
how to solve it for windows?

Sidharth said...

hi,
can you pl. post your error here.