Oracle Apps DBA

My photo
More than 5+ Years of IT Experience in administering Enterprise wide Multi Vendor UNIX Servers, Oracle Databases (8i to 11gR2), Middle-tiers, Applications and Clusters. I am a Sun Certified System Administrator (SCSA) for Solaris 10, oracle 10g database certified associate(OCA), Oracle 10g Database certified professional (OCP) and Oracle E-Business suite R12 certified professionl(OCP)

Oracle Database and Applications

Monday, 26 November 2012

adoacorectl.sh: exiting with status 204 & exiting with status 150

Hi,

When  i was trying to start one of of TEST R12.1.1 applicaiton script "adoacorectl.sh" is exiting with error "adoacorectl.sh: exiting with status 204" and when trying to stop its exiting with error "adoacorectl.sh: exiting with status 204"

Error Stack when trying to start:



Executing service control script:
/u01/applR12/inst/apps/TEST_linuxerp1/admin/scripts/adoacorectl.sh start
script returned:
****************************************************

You are running adoacorectl.sh version 120.13

Starting OPMN managed OACORE OC4J instance  ...

adoacorectl.sh: exiting with status 204

adoacorectl.sh: check the logfile /u01/applR12/inst/apps/TEST_linuxerp1/logs/appl/admin/log/adoacorectl.txt for more information ...



[applerp@linuxerp1 scripts]$ adopmnctl.sh status

You are running adopmnctl.sh version 120.6

Checking status of OPMN managed processes...

Processes in Instance: TEST_linuxerp1.linuxerp1.orasol.com
---------------------------------+--------------------+---------+---------
ias-component                    | process-type       |     pid | status
---------------------------------+--------------------+---------+---------
OC4JGroup:default_group          | OC4J:oafm          |   12478 | Alive
OC4JGroup:default_group          | OC4J:forms         |   12394 | Alive
OC4JGroup:default_group          | OC4J:oacore        |     N/A | Down
HTTP_Server                      | HTTP_Server        |   12147 | Alive


adopmnctl.sh: exiting with status 0

adopmnctl.sh: check the logfile /u01/applR12/inst/apps/TEST_linuxerp1/logs/appl/admin/log/adopmnctl.txt for more information ...

[applerp@linuxerp1 scripts]$
</

Error Stack when trying to stop:


Executing service control script:
/u01/applR12/inst/apps/TEST_linuxerp1/admin/scripts/adoacorectl.sh stop
script returned:
****************************************************

You are running adoacorectl.sh version 120.13

Stopping OPMN managed OACORE OC4J instance ...

adoacorectl.sh: exiting with status 150

adoacorectl.sh: check the logfile /u01/applR12/inst/apps/TEST_linuxerp1/logs/appl/admin/log/adoacorectl.txt for more information ...
 


Solution:
=> Stop application services
=> Clear contents of the persistence directory 
=> Start application services

[applerp@linuxerp1 scripts]$ cd $ORA_CONFIG_HOME/10.1.3/j2ee/oacore


[applerp@linuxerp1 oacore]$ ls
application-deployments  config  persistence  tldcache
[applerp@linuxerp1 oacore]$ rm -rf persistence/
You have new mail in /var/spool/mail/applerp
[applerp@linuxerp1 oacore]$ mkdir persistence 




[applerp@linuxerp1 scripts]$ adopmnctl.sh status

You are running adopmnctl.sh version 120.6

Checking status of OPMN managed processes...

Processes in Instance: TEST_linuxerp1.linuxerp1.orasol.com
---------------------------------+--------------------+---------+---------
ias-component                    | process-type       |     pid | status
---------------------------------+--------------------+---------+---------
OC4JGroup:default_group          | OC4J:oafm          |   13872 | Alive
OC4JGroup:default_group          | OC4J:forms         |   13804 | Alive
OC4JGroup:default_group          | OC4J:oacore        |   13723 | Alive
HTTP_Server                      | HTTP_Server        |   13671 | Alive


adopmnctl.sh: exiting with status 0

adopmnctl.sh: check the logfile /u01/applR12/inst/apps/TEST_linuxerp1/logs/appl/admin/log/adopmnctl.txt for more information ...

[applerp@linuxerp1 scripts]$



thanks,
X A H E E R




4 comments:

Anonymous said...

Thanks for this great help keep up the good work......:-)

Anonymous said...

very helpful post ... but do u have and idea about the cause for this error.

Anonymous said...

I think the underlying cause of this error is that the persistence cache is used by the server for the services in question (OACore, OAfm etc) and the entries in persistence point to a different ip address for the server - I find I get this error when I make n/w settings changes for my virtual server (bridged to NAT etc) or when the router is on a different subnet potentially and it does not automatically reallocate the same ip address.

Anonymous said...

Thank you, that was quite helpful.