Oracle Apps DBA

My photo
More than 5+ Years of IT Experience in administering Enterprise wide Multi Vendor UNIX Servers, Oracle Databases (8i to 11gR2), Middle-tiers, Applications and Clusters. I am a Sun Certified System Administrator (SCSA) for Solaris 10, oracle 10g database certified associate(OCA), Oracle 10g Database certified professional (OCP) and Oracle E-Business suite R12 certified professionl(OCP)

Oracle Database and Applications

Monday, 10 February 2014

FRM-92101: There was a failure in form server during startup on IBM-AIX 6.1

After performing R12.1  EBS clone on IBM-AIX 6.1 for one of our customer we were not able to access EBS forms due to frm-92101 error. Forms was not launching.


Cause:

One of the application dependent library file is still exists with the old production OS username - oraprod where as system is expecting this link should be owned by oratest user (clone)

[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#ls -lrt ldflags
lrwxrwxrwx    1 oraprod  dba              44 Feb  5 15:42 ldflags -> /oraprod/R12/apps/tech_st/10.1.2/lib/ldflags

Solution:

1) remove soft link for ldflags
2) create new softlink
3) stop application services
4)  run make command for form libraries
5) start application services

>> Remove soft link:

[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#rm ldflags
[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#ls -lrt ldflags
ldflags not found
[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#

>>  Create new soft link:

[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#ln -s $ORACLE_HOME/lib/ldflags ldflags
[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#

>>  Stop application services: 

>>  Install form libraries using make command

[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/forms/lib32]#make -f ins_forms.mk install

>> Verify ldflags is owned by proper user:

[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#ls -lrt ldflags
lrwxrwxrwx    1 oratest  dba              48 Feb 10 15:04 ldflags -> /oratest/R12_app/apps/tech_st/10.1.2/lib/ldflags
[oratest@ORAEBSBKP[/oratest/R12_app/apps/tech_st/10.1.2/lib32]#

>> start application services

After restarting application services forms are launching  normally without any issues.

thanks for reading :)

regards,
X A H E E R

2 comments:

Techno Functional said...

Here is solution for windows environment

http://mujahidalishahani.blogspot.ae/2014/10/frm-92101-there-was-failure-in-forms.html

Blogger said...

BlueHost is ultimately the best hosting company for any hosting services you need.